Baby BMW Forum banner
  • The monthly Photo Competition is back! Click HERE to enter
1 - 6 of 6 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter · #1 ·
Hi guys, new M2 comp owner. Recently traded up from my beloved 140.

New car is fantastic, but I have an issue with hot restarts. After driving hard there is a slight hiccup when restarting the car. I first noticed this when the auto start/stop was on. I pulled up at a red light and when the car restarted the rpm dropped to around 400 for a second and then went back to normal idle speed (seems to be 650ish on my car). I've reproduced the fault a few times by restarting the car when it's nice and warm. Doesn't happen every time though, and it's not a rough or lumpy idle either, just one slight cough and then back to normal.

I still have my old mhd dongle and so checked codes. I was half expecting a miss fire code, but there was nothing, only some shadow codes about the start/stop system (I used to get these on the 140 too). Car totally fine otherwise. It's completely stock, 2020 with 15k miles.

Weird. It almost seemed like vapour lock, as though the fuel had percolated a bit in the injector, but I was under the impression cars don't do that anymore?

Any ideas?

Sent from my CPH2089 using Tapatalk
 

·
Super Moderator
Joined
·
344 Posts
Throttle body springs to mind - could potentially need a clean?

You mention that you can reproduce the issue, and given your vehicle will still be under warranty - might be worth a trip to the dealer for peace of mind?
 

·
Registered
Joined
·
222 Posts
Discussion Starter · #3 ·
Throttle body springs to mind - could potentially need a clean?

You mention that you can reproduce the issue, and given your vehicle will still be under warranty - might be worth a trip to the dealer for peace of mind?
Just checked my notes for the 140 (I am a PROPER nerd, aren't I) and she used to do the same thing from time to time. In fact the idle is generally smoother on this S55 than on the B58, and she starts easier. My 140 would take 8 or 9 cranks some days.

I'm reluctant to take it to the dealer, I'm almost certain that will be a waste of time (tadts).

Still no codes. I guess I'll just keep an eye on it.

My money is still on fuel vaporising in the line/injector due to heat. The pump switches off, pressure drops, boiling point lowers, hot engine makes vapour, yada-yada-yada.

Bleh. This is what you get for being a paranoid strange noise detective. I struggle to enjoy cars sometimes because I'm watching everything like a hawk, waiting for something to go wrong.

Sent from my CPH2089 using Tapatalk
 

·
Registered
Joined
·
428 Posts
Just checked my notes for the 140 (I am a PROPER nerd, aren't I) and she used to do the same thing from time to time. In fact the idle is generally smoother on this S55 than on the B58, and she starts easier. My 140 would take 8 or 9 cranks some days.

I'm reluctant to take it to the dealer, I'm almost certain that will be a waste of time (tadts).

Still no codes. I guess I'll just keep an eye on it.

My money is still on fuel vaporising in the line/injector due to heat. The pump switches off, pressure drops, boiling point lowers, hot engine makes vapour, yada-yada-yada.

Bleh. This is what you get for being a paranoid strange noise detective. I struggle to enjoy cars sometimes because I'm watching everything like a hawk, waiting for something to go wrong.

Sent from my CPH2089 using Tapatalk
You are in for a treat if you are paranoid of odd noises, the M2C/S55 makes all sorts of strange noises, I have had random idle fluctuations, random whirring, a random stall with DCT sat in traffic. None of these ever happened again and done nothing to ever correct them, completely random and never turned into anything more or serious. A strange old car but a brilliant one

I did remove cold start, and code out stop/start and car definitely seems to be happier however.
 

·
Registered
Joined
·
222 Posts
Discussion Starter · #6 ·
You are in for a treat if you are paranoid of odd noises, the M2C/S55 makes all sorts of strange noises, I have had random idle fluctuations, random whirring, a random stall with DCT sat in traffic. None of these ever happened again and done nothing to ever correct them, completely random and never turned into anything more or serious. A strange old car but a brilliant one

I did remove cold start, and code out stop/start and car definitely seems to be happier however.
I know right, I'm also going down the diff clunk/thump rabbit hole...

But man, I tell you. I am absolutely in love with this girl! Can't get enough, especially throwing her into bends. The grip is insane, yet such delicate, immediate steering response. LOVE IT!

Cars that are perfect don't have any personality .

Sent from my CPH2089 using Tapatalk
 
1 - 6 of 6 Posts
Top