Baby BMW Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hello all,
My 1 year old 120d gets a very loud knock/rattle inside the dash. It only happens when you labour the engine, e.g. crawling in 1st or 2nd gear (especially holding it back with the brakes), or in slow moving traffic when the engine is labouring slightly.

It seems to be coming from behind the key fob or vents and sounds like something flapping about - kind of like the noise when you hold a ruler over the edge of a desk and flick it; d-d-d-d-d, kind of a thing. Hard to describe but if you have it you'll probably understand what I mean.

Anyway, has anyone else had this? If is something I can fix by packing out something I'll have a go, otherwise it will have to go in to be looked at.

Cheers,
T.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Yes, its from high up inside the dash, in the area behind the key fob socket and just to the right of the centre dashboard vents. Opening and closing the vents makes no difference, it's not coming from the ally dashboard trip strip or anything external and you can't replicate it by banging or prodding the dash.

You can also hear it for a fraction of a second when the engine starts so I guess it occurs when the engine vibrations hit a specific frequency. It's not a creak but a loud clatter thats lasts maybe half a second or so at specific engine revs - something flapping up and down inside maybe.

I'm wondering if it's just my car as its not the kind of thing you could miss..!

cheers,
T.
 

·
Registered
Joined
·
513 Posts
This is a long shot but try the following. Remove the engine cover, take the car on a run that would usually create the sound and see what happens. If it is stops, then it is purley the engine cover that needs re-seating where it slides in at the rear of the engine. I had similar a problem, especially when labouring and at certain revs, tried holding all sorts of bits on the dash, it was driving me :censored: mad . If you have moved the engine cover recently then it is highly likey you will have the cure :)

Hope it works.
 

·
Registered
Joined
·
4 Posts
I had exactly the same problem with the engine cover, I had removed it and not tightened it properly on one corner, the vibration was unbelievable, you would think I had dropped a spanner in the engine block!

try that mate, it's a easy fix if it is that.

Regards

Gary
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
Thanks both, its coming from right far forward by the screen and it does sound like something big and flat flapping up and down so the engine cover could well be it. I've not had the cover off but I guess it could have been left like that after the last service if they removed it for any reason.

I've actually booked it in for Wednesday but will have a look tonight and report back.

Cheers,
T.
 

·
Registered
Joined
·
34 Posts
Guess its the strut brace type thing that fixes to the top of your suspension tops.

Sounds exactly the same as a problem i had with mine. Identical in fact.

Tightened the bolt at the dealer. Problem solved. It sounded like it was at the back of my Satnav screen for me.

GT
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #8 ·
Thanks Gary and Dave - it was exactly what you both said.

I popped the bonnet tonight and checked the strut brace - all ok. Next I grabbed the engine cover and discovered it could be moved up and down so it banged on the bottom of the scuttle panel. I took it off, slid it back on and problem solved.

Just got to remember to cancel the appointment with the dealers now,

cheers,
T.
 

·
Registered
Joined
·
513 Posts
Baxter said:
Thanks Gary and Dave - it was exactly what you both said.

I popped the bonnet tonight and checked the strut brace - all ok. Next I grabbed the engine cover and discovered it could be moved up and down so it banged on the bottom of the scuttle panel. I took it off, slid it back on and problem solved.

Just got to remember to cancel the appointment with the dealers now,

cheers,
T.
Pleased that was it :) . I discovered the problem by accident but suffered it for about a week. Who would think to look there?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top