Baby BMW Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey! I have a bit of an issue with my nav now being stuck on "loading" and not working since the dealer updated the system in my 1 series (even though I told them not to!). I had previously used a usb method to install CarPlay in the car and that must be what broke it. Right now I just want to get it back to OEM properly (so no hacks/dodgy codes), not too fussed about CarPlay as I no longer have an iPhone! Can anyone help?
 

·
Registered
Joined
·
67 Posts
you need to clear the fake FSC codes, then load the OEM codes - after that it will work again like factory.

To do this you will need a windows PC and ENET cable - of you have those I can probably help you remotely.
 

·
Registered
Joined
·
276 Posts
Not that I want to hyjack this thread but I took my 140 to my local dealers for an MOT last year. They insisted they would update the software. I told them under no circumstances where they do do anything that was not described by the ministry of transport for assessing the cars road worthiness. They simply said 'we will it anyway as it's company policy.' I corrected them as I own the car outright it's not even on finance. Prior to dropping it with them I moved the OBD port and put a dummy in its place with 110v AC across the power terminals. I told them this on film as I dropped the car off and warned them I was recording. Said it was an anti theft device and I couldn't disable it. They decided not to try to plug in!! I had even put a warning 110v sticker over the port just in case and recorded the fact as I parked the car and walked in to the dealer.
 

·
Registered
Joined
·
67 Posts
Mrbarry said:
Not that I want to hyjack this thread but I took my 140 to my local dealers for an MOT last year. They insisted they would update the software. I told them under no circumstances where they do do anything that was not described by the ministry of transport for assessing the cars road worthiness. They simply said 'we will it anyway as it's company policy.' I corrected them as I own the car outright it's not even on finance. Prior to dropping it with them I moved the OBD port and put a dummy in its place with 110v AC across the power terminals. I told them this on film as I dropped the car off and warned them I was recording. Said it was an anti theft device and I couldn't disable it. They decided not to try to plug in!! I had even put a warning 110v sticker over the port just in case and recorded the fact as I parked the car and walked in to the dealer.
That's a bit extreme but I like your thinking...

I just put a toggle switch accross the CAN-H to disable communication with the car, that way they could never update anything - I have many tales of dealers runing cars....
 

·
Registered
Joined
·
276 Posts
It may be extreme, but I left it that way. I liked the idea that if some low life car thief tried to plug in they would get their hardware fried.
110v ac centre tap to earth is 55v so not like mains but it will fry electronic stuff. The human body won't effectively conduct at 55v. Gone are the days of SELV and PELV, now we just have LV and HV, but the theory is still the same. A yellow plastic cap with a 110v warning stops accidental plug-ins (3D printed)
 

·
Registered
Joined
·
94 Posts
I posted a thread recently that the main dealer refused to update the software on my fiancées F20 because they detected software manipulation and said chances were that the sat nav would break, shame there is no consistency between dealers
 

·
Registered
Joined
·
1 Posts
you need to clear the fake FSC codes, then load the OEM codes - after that it will work again like factory.

To do this you will need a windows PC and ENET cable - of you have those I can probably help you remotely.
I've stupidly allowed BMW to update my car, and the navigation is stuck on loading. I realise now, I should have uninstalled my non-factory Carplay installation.
They advised that because I had manipulated the headset by installing Carplay it had caused the Nav to fail.
Can you advise on how to get this restored? I pay for the BMW booster pack, which includes updated maps, so it would be good to get the use of it. Will it automatically reinstall the BMW pack? I also intend to reinstall Carplay.
My argument that they should ensure that there is nothing on the system that will cause a problem, before they install updates, fell on deaf ears. And now they want to charge me to get it back to the state it was in before I gave it to them.
 
1 - 12 of 12 Posts
Top