Baby BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Good afternoon

I don't know if it's just me but I find my temperature gauge seems to under read or take a while to adjusting from cold temperatures. I got in my car at lunchtime today to move it from blocking somebody in my works car park and it was reading +1.5C. I know it's cold but it wasn't that cold. When I left work it had picked up to about 6C which seems slightly closer to the actual temperature (but still a bit out by a few degrees).

I had an issue with this before in October when it was fairly mild and the temperature was under reading by about 10 degrees. (T Shirt weather in the afternoon and reading 8C). I took it into BMW and they replaced the temperature sensor. I'd say it's only been six weeks since then and I'm not doing a lot of driving (30 miles a week maybe even less at the moment).

Are BMW temperature gauges always a bit slow to acclimatise to the outdoor temperature? I don't really want to ask the dealership to look at it again but next time it's in for servicing I might mention it. Just trying to see if anyone else experiences this occasionally.
 

·
Registered
Joined
·
1,560 Posts
The outside temp sensor is located just in front of the front left wheel behind the arch liner,
7A646404-1BDF-473C-B638-543788E6979C.jpeg

my cars outside temp has never appeared to be incorrect, but as mentioned above, where you are parked will alter the accuracy some what until you get under way, as with any vehicle I've owned I generally find you need to give it a mile or two of driving to be sure it's displaying the correct figure.
 

·
Registered
Joined
·
53 Posts
Mine did this today.

Got in and I got 0.5'C and a low temp warning. It was nowhere near that cold.
By the time I'd driven a couple of hundred metres down the road it had climbed to 7'C

First time I've noticed this.
Had bad flashbacks to my Alfa Romeo, whose temperature display was more like a random number generator.
 

·
Registered
Joined
·
56 Posts
I got similar issue today, outside temperature is 19c and showing up 13.5c on dashboard .

Moved it to sun and now changed to 16c . Was ok earlier or could be not accurate at hotter weather or so.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
Funnily enough I’ve had a reoccurrence of this issue. Took it back into BMW in March. They investigated further and said the sensor was dirty further back or the wiring loom was dirty and needed cleaning. They cleaned it up and said it was now working fine.

The problem appears to be back though. This week during the warmer afternoons the temperature is stuck at 13C whereas in reality it’s closer to 17C. The only way this resolves is when I take it for a run on the dual carriageway at speeds around 50mph so it might be an airflow issue around the sensor.

Don’t really want to take it in again to BMW for this issue as it is only a minor inconvenience but would rather get it sorted especially as it’s under warranty.
 
1 - 6 of 6 Posts
Top