Baby BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all, first post.

Just bought myself a cheap 130i today, possibly the cheapest in the country at the time. Saw it on FB market place just over 30 miles from where I live in Plymouth and a few miles down the road from my work yard. Despite the idrive not working and a few other issues I decided to buy it anyway as I like tinkering with cars.

Spec wise, xenon lights, business idrive and the rest standard 130i I believe.

Got a 370hp 8p S3 that is hardly getting used, so decided to free up some money and replace it. And having had an E46 M3 and E85 Z4 3.0i in the past I was keen to get back into a BMW. Audi will be going up for sale soon if anyone knows of an interested party, point them my way.



The 130i is high millage at 174 thou, so understandably has a few issues.

The main one being a dead idrive system. Screen flips up and down on engine on/off and you can hear the cd drive spinning, but wont eject. That's it, screen is dead, no sound etc. Could someone please point me in the direction of a fault finding thread, had a search but can't find anything. I know you can send the ccc off to be fixed, but I need to know if that is in fact the fault, and where it and modules etc are located.

No real plans other than to give it a good service, change the tensioner, idler and belt and make sure it is in good running order. If after running it for a while I still like it I will probably look out for a lower milage, modified version. You know, suspension, big brakes, M3 LCA, remapped etc. Not financially a clever move modding such a high milage car.

Here it is after a quick clean.







Air Inlet part was all cracked on the lower side when I removed it, so gave it a plastic weld.

 

·
Registered
Joined
·
54 Posts
Best plan is to get the true BMW codes read using ISTA+. This will identify the errors and in many cases propose diagnostic tests on the affected components.
 
1 - 4 of 4 Posts
Top