Baby BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
Hi Guys,

A bit of an unusual one here.
My dad's Merc C207 2.1CDI has developed a bit of strange issue, where a check engine kick in if he does a steady speed of around 80mph. Accelerating up to this speed or going past there doesn't seem to be an issue, but as soon as he starts 'cruising' at that speed the light kicks in. Although the fault is displayed, the car still runs fine and accelerates fine, only thing my dad noticed is the car shifts gears a lot sooner, below 2500rpm even under harder acceleration?

Plugged the car into the diagnostic and it was showing a DPF fault, can't remember the fault code but the description was stating low drive train pressure?? Has anyone else had a similar issue?

I will get a chance to see the car probably this weekend, so will plug it in and check history to see exactly what code popped up.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #2 ·
Just a quick follow up, I've been reading up a little bit about this issue and seems many people had issues with exhaust pressure sensors which were throwing up DPF faults and CEL lights. So a small order made for a new exhaust pressure sensor and will have it fitted some time this weekend to see if it rectifies the issue.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
So turns out the exhaust pressure sensor was faulty, throwing up error codes...dpf related codes. Fairly cheap and quick fix to the issue, just a bit uncomfortable to work on as it is so close to the firewall/bulkhead.
 

·
Registered
Joined
·
2,629 Posts
So turns out the exhaust pressure sensor was faulty, throwing up error codes...dpf related codes. Fairly cheap and quick fix to the issue, just a bit uncomfortable to work on as it is so close to the firewall/bulkhead.
Great news Crashy!!!!!
 
1 - 4 of 4 Posts
Top