Baby BMW Forum banner
  • The monthly Photo Competition is back! Click HERE to enter
1 - 19 of 19 Posts

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #1 ·
Hi All

Thought I'd share a short tale of woe documenting an experience I've had recently with my Check Engine Light (CEL).

I'd not owned my M2 long when I got a CEL (no other warnings on the dash, not even a notification in the 'check control' section of the iDrive. Plugged my phone in, checked the codes and I had a "CD840A - DME, PT Can: Communication fault" logged. I cleared the code and the CEL went away along with the code. For those not in the know, PT stands for PowerTrain.

About a week later, back. Same again. Cleared, rinse and repeat, roughly every week. I did a bit of 'The Goog' and found people with chaffed looms and other kinds of problems giving this fault. At this point, I could see the future and it involved a BMW dealership and lots of money leaving my bank account.

Something in my lizard brain was nagging at me though. My car is fitted with an Autowatch Ghost II imobiliser. This stops the engine when selecting drive on the DCT if the disarm sequence hasn't been followed. The CELs weren't being triggered by my not disabling the Ghost, but it still niggled in the back of my mind.

I reached out to Autowatch today and their helpful chap on the phone took my details and said he'd get someone in their tech dept. to come back to me. Sure enough a chap called me today at lunch time.

Him: "Check engine light?"
Me: "Yeah..."
Him: "Roughly every week?"
Me: "Yeah..."
Him: "PT Can error, cleared with a scan tool?"
Me: "Yeah..." laughing at this point
Him: "Yep, that's the Ghost II. Old firmware from around 18 months ago. There's a fix, just visit an installer and they'll update it."

So, I'm assuming that whoever fitted my Ghost used older stock that hadn't been updated recently and I've now got this issue. However, the story doesn't end there. I rang around a couple of places, seeing if I could find someone who'd update this thing. The only one that got back to me wants £180 to flash the firmware :LOL:

It gets better; I'll have to add a bunch of cash to that as well as I live on the Isle of Wight and there's no Ghost installers over here, so I'll need to catch a ferry to get it done.

Needless to say, I'm calling Autowatch back tomorrow to see what they say. £180 to update the thing is a bit rich given that it's their buggy firmware that's caused the issue. Also, what if the Ghost had not occurred to me as a possible cause? I could have spent a boatload of cash at a dealer trying to diagnose a problem that's nothing to do with the car at all.

Anyway, I'll update as I get deeper into this. I wanted to document it just in case anyone else gets affected by this issue (unlikely as that may be).
 

·
Super Moderator
Joined
·
344 Posts
Very disappointing that they want to charge £180 to solve a problem that's completely on their end. Hope they waive that for you as a matter of goodwill.

Hats off to you though for having figured it out!

EDIT: Might be worth just pinning this thread Major - could be an oasis for many with this problem!
 

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #4 ·
Quick update from today.

I called Autowatch back, asked if there was any way to update the FW myself and was told most definitely not as they don't release the tools to the general public, only registered installers. Perfectly reasonable for a security product. The chap that I really wanted to talk to about their installers wanting savage money for a 5 minute FW update wasn't there today. I'll try him again tomorrow. I should point out that they're the manufacturer and all the installers are approved, but private, so Autowatch has no control over charges.

I found a name and mobile number on a bit of paper included with the Ghost 2's installation blurb. Didn't know I had it. Called the guy today and he told me to call RS Connect (the company that he works for). Called them, and they told me that I had to call 999 Vehicle Security as they sub-contract all install work to RS Connect.

Sighing at this point.

Called 999 Vehicle Security (a.k.a. Ghost Installations) and I got the impression the person I spoke to didn't really know what firmware was, let alone what I wanted to have done to it. However, they took my details and told me that someone would call me back. I wasn't hopeful, but I have just had a call from RS Connect and they are over here on the Isle of Wight next week and will do the update for me. With a bit of luck, this will solve the repeat appearance of the CEL.

There is a caveat to this good news however. They're charging me £144 for the update. This could be worse as at least I don't have the ferry charge to get to the mainland to add on but it's still a kick in the proverbials. Can't blame a private company for charging for their time though.

When I call Autowatch back tomorrow, I'm going to express my displeasure at having to pay someone to update their buggy firmware. Maybe I'll get lucky and they'll foot some of the bill. Probably not though, eh? :rolleyes:

@dxnnyk I could pin this, but I feel that it's probably a very niche problem and that I've included enough keywords that a Google / site search should link here for anybody else having this issue.
 

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #8 ·
Quick update.

They let me down. RS Connect were supposed to come to me on Weds 10th to update the firmware. The day before, they called me and told me that they had to cancel due to staff sickness and that they'd re-arrange for Friday 12th. Friday morning came and I got another call apologising as the chap they'd had pencilled in to cover the sick guy didn't have accreditation for Ghost immobilisers :rolleyes:

They've re-scheduled for the Tues 30th Aug. Quite annoying as I've already paid for this service on a pro-forma invoice. However, hopefully on the 30th, it'll get sorted.

I wrote an email complaint to Autowatch on the 3rd August. No reply as yet. Will have to phone them when I get 5 minutes and make my feelings known.
 

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #9 ·
Surprise, surprise! RS Connect have bailed on me again! :LOL:

The appointment for updating the firmware was on Tues 30th between 10am and 2pm per my post above. At 11:30 I called them to confirm that they were still attending (as I hadn't heard from their engineer). The person I spoke to told me, yes, they were still coming.

Fast forward to 2:15pm. I call again as I'd heard nothing. "Ahh... let me get a manager to call you back." I'm fuming at this point, lol. A manager did indeed call me back and the excuse was that the 'junior' engineer in my area today didn't have access to a laptop and therefore couldn't update the Ghost firmware. A 'senior' engineer is visiting me next week (Thurs) to do the update. Apparently, he'll have a laptop!

You couldn't make it up. If I hadn't already paid them via a pro-forma, I think I'd have told them to poke it.
 

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #13 ·
Well, quelle surprise, RS Connect cancelled again and moved the Ghost update appointment from today to Monday 12th. This is now the 4th time. At this point, I really wouldn't recommend this company. Although, I will say that they're always super-polite and helpful on the phone.

Same reason; confusion over days where a laptop-equipped engineer will be available in my area. This is despite me confirming three times the other day on the phone that today was definitely going to be the day. Fun & games.
 

·
Registered
Joined
·
383 Posts
Well, quelle surprise, RS Connect cancelled again and moved the Ghost update appointment from today to Monday 12th. This is now the 4th time. At this point, I really wouldn't recommend this company. Although, I will say that they're always super-polite and helpful on the phone.

Same reason; confusion over days where a laptop-equipped engineer will be available in my area. This is despite me confirming three times the other day on the phone that today was definitely going to be the day. Fun & games.
I’m pissed and I’m not even the one who has to get this crap updated… any chance of getting a different ghost immobiliser installed? I know it’s more money but how much more of your time are they going to waste?…
 

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #15 ·
I’m pissed and I’m not even the one who has to get this crap updated… any chance of getting a different ghost immobiliser installed? I know it’s more money but how much more of your time are they going to waste?…
Ghosts are quite expensive, so I don't want to go down that route :)

Hoping that Monday it gets sorted!
 

·
Super Moderator
Joined
·
921 Posts
Discussion Starter · #18 ·
So, this appears so far to have worked. No CEL since and I was able to flash the CS-style DCT software yesterday.

This is something that I'd been unable to do whilst the Ghost was malfunctioning. I don't think I mentioned it above, but when I tried to flash it previously, MHD stated "DCT not found" which I thought was amusing if nothing else.

I'll continue to monitor it, but I'm considering this resolved for now.
 

·
Registered
Joined
·
26 Posts
Don't know if your still around but my M2 C has a cel come on, every time it's the nearside rear indicator sometimes it stops sometimes it's normal bit annoying at least, I was going to have it removed but that seems difficult to get it done due to availability
 
1 - 19 of 19 Posts
Top