Baby BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi Guys

So every time I start the car and start driving, the first press of the break pedal always has like a wall at 50% breaking pressure, it feels as if the breaks dont work for 1-2 seconds and then activates, while being pressed at the wall the car also pulls to the left, and once the wall is broken the breaking resumes to normal.

We have done a lot of testing, replaced the non return valve break pipe and it still has an issue, I have even figured out how to initiate this more often, as we have removed the DSC/ABS plug, start the car, drive it and there is no problem or wall, then when you stop switch off, and plug the controller unit plug in, the very first break pedal push has a wall mid way.

We are stuck for solutions, and have had two BMW techs look at it with no solution, and the BMW Dealership doesnt have a clue eirther and they saying that replacing the DSC Unit is a option at $2100 dollars.

I have googled online and haven't seen any one with this issue.

Some speculation of the issues from Online and Mechanics, not sure if this helps...
  • ABS Sensor Replacement ( Can Cause Issues with DSC )
  • Recalibration of the DSC Unit ( BMW Dealership doesnt do this, anyone know if its possible ? )
  • Master Cylinder Seal Inverting
Please can someone assist if they have any information...
 

·
Registered
Joined
·
1,765 Posts
have you bled the brakes after the valve replacement?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Haven't done a bleed... The car is booked in for the bleed on Tuesday .. fingers crossed it works... But due to the plug being unplugged and the fault not being there is why I thought it could be something else
 

·
Registered
Joined
·
281 Posts
It sounds like something to do with the brake power assist / master cylinder to my untrained eyes, as if it's taking a while to build up vacuum (I'm assuming these fancy modern cars still use vacuum power assist?)
 
1 - 6 of 6 Posts
Top