2E0F valvetronic system deactivated

Find out more about the BMW 1 Series E81, E82, E87, E88.
Manufactured from 2004 to 2013

Moderators: Lambster, marco_polo, Rich196, babybmwadmin, Producethis

steveo08
Knowledgeable Member
Knowledgeable Member
Posts: 116
Joined: Wed Jun 26, 2013 2:15 pm
Location: Loughborough

2E0F valvetronic system deactivated

Post by steveo08 » Thu Oct 12, 2017 6:50 pm

Has anyone came across this code?:

2EOF - valvetronic system deactivated, adjustment fault too frequent.

No CEL and car still pulls but a little rough on idle, small pulsing surges
2010 n55 135i space grey. Red leather. Bmwp exhaust and lots of bmwp goodies, Darklines. BMS chargepipe, wagner evo fmic, mhd stage 1+

dannyazs87
Junior Member
Junior Member
Posts: 6
Joined: Sat Feb 03, 2018 5:20 am

Re: 2E0F valvetronic system deactivated

Post by dannyazs87 » Sat Feb 03, 2018 5:30 am

Were you able to fix this? Having same code pop up. Erased but shows back up imediatelly. No cel, no issues just a bit of weird idle at cold start for about 30 seconds. Any help greatly appreciated.

steveo08
Knowledgeable Member
Knowledgeable Member
Posts: 116
Joined: Wed Jun 26, 2013 2:15 pm
Location: Loughborough

Re: 2E0F valvetronic system deactivated

Post by steveo08 » Sat Feb 03, 2018 8:23 am

Are you tuned?
2010 n55 135i space grey. Red leather. Bmwp exhaust and lots of bmwp goodies, Darklines. BMS chargepipe, wagner evo fmic, mhd stage 1+

dannyazs87
Junior Member
Junior Member
Posts: 6
Joined: Sat Feb 03, 2018 5:20 am

Re: 2E0F valvetronic system deactivated

Post by dannyazs87 » Sat Feb 03, 2018 3:38 pm

No. 100% stock. Its a 11 x5.

steveo08
Knowledgeable Member
Knowledgeable Member
Posts: 116
Joined: Wed Jun 26, 2013 2:15 pm
Location: Loughborough

Re: 2E0F valvetronic system deactivated

Post by steveo08 » Sat Feb 03, 2018 4:07 pm

Worst case scenario. You could need a new valvetronic motor ( they need to be calibrated). Or if you are lucky like me a reset of adaptations did the trick
2010 n55 135i space grey. Red leather. Bmwp exhaust and lots of bmwp goodies, Darklines. BMS chargepipe, wagner evo fmic, mhd stage 1+

dannyazs87
Junior Member
Junior Member
Posts: 6
Joined: Sat Feb 03, 2018 5:20 am

Re: 2E0F valvetronic system deactivated

Post by dannyazs87 » Sat Feb 03, 2018 4:21 pm

How do i do the adaptation? Turning ignition on and leaving it on dossnt seem to do anything. Noticed the code after i changed the battery and was checking readiness with my launch x431

steveo08
Knowledgeable Member
Knowledgeable Member
Posts: 116
Joined: Wed Jun 26, 2013 2:15 pm
Location: Loughborough

Re: 2E0F valvetronic system deactivated

Post by steveo08 » Sat Feb 03, 2018 4:45 pm

So to an indy garage or bmw and get them to do it you need software.
2010 n55 135i space grey. Red leather. Bmwp exhaust and lots of bmwp goodies, Darklines. BMS chargepipe, wagner evo fmic, mhd stage 1+

dannyazs87
Junior Member
Junior Member
Posts: 6
Joined: Sat Feb 03, 2018 5:20 am

Re: 2E0F valvetronic system deactivated

Post by dannyazs87 » Sat Feb 03, 2018 4:47 pm

You know anyone that can do it remotely?i have a cable and the inpa software, just dont know my way around it.

steveo08
Knowledgeable Member
Knowledgeable Member
Posts: 116
Joined: Wed Jun 26, 2013 2:15 pm
Location: Loughborough

Re: 2E0F valvetronic system deactivated

Post by steveo08 » Sat Feb 03, 2018 5:26 pm

Try b&r dagnostics they are in the foru sponsor bit on this forum
2010 n55 135i space grey. Red leather. Bmwp exhaust and lots of bmwp goodies, Darklines. BMS chargepipe, wagner evo fmic, mhd stage 1+

dannyazs87
Junior Member
Junior Member
Posts: 6
Joined: Sat Feb 03, 2018 5:20 am

Re: 2E0F valvetronic system deactivated

Post by dannyazs87 » Sun Feb 04, 2018 2:46 am

Found out my Launch scanner can do the relearn. Did it twice successfull and the 2e0f code is still there. Car drives good and just a few seconds of rough idle on cold start so maybe ill wait it out untill it gets worse or i get more codes. Thanks for the help.

dannyazs87
Junior Member
Junior Member
Posts: 6
Joined: Sat Feb 03, 2018 5:20 am

Re: 2E0F valvetronic system deactivated

Post by dannyazs87 » Fri Feb 09, 2018 2:58 am

Had the code 2e0f also on my 11 x5 with a x35i n55 engine for a few months, car just turned 100k miles. Got a dme firmware update and its gone. Guess there was a issue that bmw was able to fix with software update. Note that there was no check engine light and no simptoms besides a bit of a loss of power when backing up out of the driveway on a cold day (cold start). Did the relearn successfully on the ecentric sensor before and error wouldnt go away. Car runs a bit better and throttle more responsive. I got all the ecu's updated and at first had issues with 4x4 and dsc would turn on after drivig a few miles but a steering angle sensor calibration seems to have fixed that issue. Would recomend only a dme update if everything else works well. Been a few days and no more codes, will update if anything ckmes back but before the valvetronic system would be disabled imediatelly after code being reset. Hope this helps someone

yenlinyin
Junior Member
Junior Member
Posts: 1
Joined: Thu Mar 29, 2018 5:11 pm

Re: 2E0F valvetronic system deactivated

Post by yenlinyin » Thu Mar 29, 2018 5:29 pm

I had the same 2E0F for several weeks on my 2013 X5 x35i that just went over 66K miles along with a CEL. At first I went to a private garage (in NJ) who specializes in European cars. He diagnosed my car and suggested to replace my battery than to either replace the valvetronic servomotor (plan b) or go back to dealer for reprogramming (plan a). Since he couldn't do the reprogramming, I only had him to replace the battery ($350) but then the CEL went away.

Also, it is clear that plan a would be a lot cheaper though it could be a waste but I still tried. I went to Morristown BMW (in NJ) yesterday and explained the code I read from OBD and asked for reprogramming. I got my car back today and the code was gone. Below is what the technician wrote on my report and I would like to share with you in case you have the same issue-

Issue
Initiaize the valvetronic system through ISID failed (valvetronic system lost in initialization)
Resolution
Checked for faults. Found faults for valvetronic system, ran test plan.
Checked for stiftness in the motor and shaft. Found none.
Verified that the valvetronic system needed to be initialized.
Initialized the valvetronic system. Cleared faults.
Retested. All good

Now the cost
Diagnosis: $158 (but covered as part of reprogramming if you do it)
Reprogramming: $239.37 + tax ($15.86 in NJ)

This makes my total to $255.23 (with dealer) + $350 (with a very honest and trustworthy mechanic that I will go there going forward)

bsad0521
Junior Member
Junior Member
Posts: 2
Joined: Tue Oct 02, 2018 11:42 pm

Re: 2E0F valvetronic system deactivated

Post by bsad0521 » Thu Oct 04, 2018 5:17 pm

Hey guys having the same issues with just the 2e0f code and a little rough idle on cold starts. I have a vvt motor I can put in but was wondering if I should just update the dme first. For those of you that have updated the dme, has any of the issues come back at all? Also did the relearn on the limit stops and it worked for a little while but the code came back.

steveo08
Knowledgeable Member
Knowledgeable Member
Posts: 116
Joined: Wed Jun 26, 2013 2:15 pm
Location: Loughborough

Re: 2E0F valvetronic system deactivated

Post by steveo08 » Thu Oct 04, 2018 10:40 pm

Never had the code or rough idle come back since the dme update.
2010 n55 135i space grey. Red leather. Bmwp exhaust and lots of bmwp goodies, Darklines. BMS chargepipe, wagner evo fmic, mhd stage 1+

bsad0521
Junior Member
Junior Member
Posts: 2
Joined: Tue Oct 02, 2018 11:42 pm

Re: 2E0F valvetronic system deactivated

Post by bsad0521 » Fri Oct 05, 2018 7:55 pm

hey stevo08 did you notice any loss of power since the dme update. Was reading around and some experienced a more laggy throttle when they got the update.

Post Reply

Return to “E81, E82, E87, E88 (2004-2013)”