Blue spark

Bluespark Automotive provide plug and play performance tuning solutions for Turbocharged Petrol and Diesel vehicles. We cover most BMW models and get great results from them. We are a UK company based just south of Newcastle Upon Tyne, where you are always welcome to call in for a chat.

Moderators: babybmwadmin, Producethis, marco_polo, Lambster, Rich196, eddbluespark

Swirley84
Knowledgeable Member
Knowledgeable Member
Posts: 82
Joined: Wed Nov 07, 2012 11:49 am
Location: London

Re: Blue spark

Post by Swirley84 »

I keep getting an eml over the last month or so on my 235, pops up now and again but the car drives fine - error code is P12A9

This relates to boost pressure sensor - pressure to high - unsure if this could be anything to do with my BMS intake but never had this issue before the blue spark was fitted. I’ve had it installed for about 4 months now, strange!


Sent from my iPhone using Tapatalk
235
MyMlight
Experienced Member
Experienced Member
Posts: 346
Joined: Fri Mar 02, 2018 8:50 pm

Re: Blue spark

Post by MyMlight »

Swirley84 wrote:I keep getting an eml over the last month or so on my 235, pops up now and again but the car drives fine - error code is P12A9

This relates to boost pressure sensor - pressure to high - unsure if this could be anything to do with my BMS intake but never had this issue before the blue spark was fitted. I’ve had it installed for about 4 months now, strange!


Sent from my iPhone using Tapatalk
What setting is your Blue Spark on?


2016 M135i Auto
User avatar
Barney McGrew
Enthusiastic Member
Enthusiastic Member
Posts: 1607
Joined: Mon Sep 18, 2017 2:43 pm

Re: Blue spark

Post by Barney McGrew »

I'd maybe try a lower setting on the BS or run a short while without it again, just to see if the EML goes away.

If it does then it's more likely the code is due to the BS.
2017 M140i
Swirley84
Knowledgeable Member
Knowledgeable Member
Posts: 82
Joined: Wed Nov 07, 2012 11:49 am
Location: London

Re: Blue spark

Post by Swirley84 »

Running in D at the moment, im going to check the boost sensor this weekend and may knock it down to C, if it occurs again then I take out the BS and see what happens.
Great little box though!


Sent from my iPhone using Tapatalk
235
J4CKO
Junior Member
Junior Member
Posts: 39
Joined: Tue May 29, 2018 11:24 pm

Re: Blue spark

Post by J4CKO »

I have a 2016 M135i with BS box on its been faultless since but yesterday it threw an engine check light. The code was P12A9 which is boost pressure too high, its been in for ages on Map E. I cleared the code and the light stayed off briefly, I used the car again today for a very gentle drive (fully laden going to the tip) and it threw it again without even giving it any throttle.

Any suggestions as to how to work out where the fault is, was thinking of dropping back to the lower map, say C, if that doesn't work then remove the BlueSpark and see what happens, can the boxes go faulty ?

Do the boost sensors fail ?

Any other suggestions, aside from the light the car is running fine.
J4CKO
Junior Member
Junior Member
Posts: 39
Joined: Tue May 29, 2018 11:24 pm

Re: Blue spark

Post by J4CKO »

I emailed BlueSpark at 15:35, I got an email alert on my phone like 10 minutes later from Edd suggesting what to try !

I cleared the code and took the BS off and there was a tiny bit of dampness (lot of rain recently) round the connector, so that maybe significant. Edd suggested putting the blanking plug in so I did and went for a drive, no CEL.

Came home, put the BS back on but in mode C with a plastic bag round it, went for a drive and no CEL.

So, may be ok, big thanks to Edd for the rapid response.
Post Reply

Return to “Bluespark Automotive”