Bluespark Tuning Box

Bluespark Automotive provide plug and play performance tuning solutions for Turbocharged Petrol and Diesel vehicles. We cover most BMW models and get great results from them. We are a UK company based just south of Newcastle Upon Tyne, where you are always welcome to call in for a chat.

Moderators: babybmwadmin, Producethis, marco_polo, Lambster, Rich196, eddbluespark

User avatar
MrArthur
Experienced Member
Experienced Member
Posts: 205
Joined: Mon Jan 08, 2018 4:14 pm
Location: Stockholm/Sweden
Contact:

Re: Bluespark Tuning Box

Post by MrArthur »

sspdw wrote: Thu May 10, 2018 7:09 pm When did you buy your bluespark mc arthur?
12th April 2018, but I was waiting 2 weeks before install.
Alpine White BMW M140i 5-door, MPE with carbon tips and front oval muffler delete, PiperCross filter, BlueSpark, Dragy GPS, ZF 8-speed, adaptive, HK, and mutch mutch more, witout moonroof
User avatar
BlueSatan
Knowledgeable Member
Knowledgeable Member
Posts: 61
Joined: Wed Mar 07, 2018 1:36 am
Location: Surrey

Re: Bluespark Tuning Box

Post by BlueSatan »

Looking forward to fitting this to the magnificent beast. Anyone knows a decent sportscat downpipe under £500.00. Worried of EML lights if I go decat route.
M140i SE with a few bits done to it.
@MBAN666
Swirley84
Knowledgeable Member
Knowledgeable Member
Posts: 82
Joined: Wed Nov 07, 2012 11:49 am
Location: London

Re: Bluespark Tuning Box

Post by Swirley84 »

Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
235
User avatar
MrArthur
Experienced Member
Experienced Member
Posts: 205
Joined: Mon Jan 08, 2018 4:14 pm
Location: Stockholm/Sweden
Contact:

Re: Bluespark Tuning Box

Post by MrArthur »

Swirley84 wrote: Tue May 22, 2018 3:14 pm Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
Hi,

I had the same ”drivetrain” error yesterday, driving in map D, very lumpy from 3500 rpm, i took out the box today and will send it back to Edd at BlueSpark for Update of firmware.

The car is running good without the box, no EML’s
Alpine White BMW M140i 5-door, MPE with carbon tips and front oval muffler delete, PiperCross filter, BlueSpark, Dragy GPS, ZF 8-speed, adaptive, HK, and mutch mutch more, witout moonroof
Swirley84
Knowledgeable Member
Knowledgeable Member
Posts: 82
Joined: Wed Nov 07, 2012 11:49 am
Location: London

Re: Bluespark Tuning Box

Post by Swirley84 »

MrArthur wrote:
Swirley84 wrote: Tue May 22, 2018 3:14 pm Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
Hi,

I had the same ”drivetrain” error yesterday, driving in map D, very lumpy from 3500 rpm, i took out the box today and will send it back to Edd at BlueSpark for Update of firmware.

The car is running good without the box, no EML’s
I had the codes checked and they was regarding the boost, cleared them and put the box down to map D all seems well again now!


Sent from my iPhone using Tapatalk
235
User avatar
M140 Bowker
Junior Member
Junior Member
Posts: 45
Joined: Thu Jul 13, 2017 8:08 am

Re: Bluespark Tuning Box

Post by M140 Bowker »

MrArthur wrote:
Swirley84 wrote: Tue May 22, 2018 3:14 pm Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
Hi,

I had the same ”drivetrain” error yesterday, driving in map D, very lumpy from 3500 rpm, i took out the box today and will send it back to Edd at BlueSpark for Update of firmware.

The car is running good without the box, no EML’s
Iv had the drivetrain error a couple of times and it goes into a limp mode, both times this has happened it has been low on fuel 25 odd miles range and once was pulling hard off a island and the other was accelerating up a hill. Iv replicated both of these (same place) when Iv got a normal amount of fuel and nothing happened. Could be a fuel pick up problem I thought as it’s never happened without a low fuel level.


Sent from my iPhone using Tapatalk
User avatar
MrArthur
Experienced Member
Experienced Member
Posts: 205
Joined: Mon Jan 08, 2018 4:14 pm
Location: Stockholm/Sweden
Contact:

Re: Bluespark Tuning Box

Post by MrArthur »

M140 Bowker wrote: Fri May 25, 2018 6:16 pm
MrArthur wrote:
Swirley84 wrote: Tue May 22, 2018 3:14 pm Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
I allways use 99 octane fuel, so Its not that.

Hi,

I had the same ”drivetrain” error yesterday, driving in map D, very lumpy from 3500 rpm, i took out the box today and will send it back to Edd at BlueSpark for Update of firmware.

The car is running good without the box, no EML’s
Iv had the drivetrain error a couple of times and it goes into a limp mode, both times this has happened it has been low on fuel 25 odd miles range and once was pulling hard off a island and the other was accelerating up a hill. Iv replicated both of these (same place) when Iv got a normal amount of fuel and nothing happened. Could be a fuel pick up problem I thought as it’s never happened without a low fuel level.


Sent from my iPhone using Tapatalk
Alpine White BMW M140i 5-door, MPE with carbon tips and front oval muffler delete, PiperCross filter, BlueSpark, Dragy GPS, ZF 8-speed, adaptive, HK, and mutch mutch more, witout moonroof
J4CKO
Junior Member
Junior Member
Posts: 39
Joined: Tue May 29, 2018 11:24 pm

Re: Bluespark Tuning Box

Post by J4CKO »

Hows everyone getting on with their BlueSpark boxes ?
Dansta
Knowledgeable Member
Knowledgeable Member
Posts: 90
Joined: Tue Mar 21, 2017 11:08 pm

Re: Bluespark Tuning Box

Post by Dansta »

MrArthur wrote: Fri May 25, 2018 1:43 am
Swirley84 wrote: Tue May 22, 2018 3:14 pm Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
Hi,

I had the same ”drivetrain” error yesterday, driving in map D, very lumpy from 3500 rpm, i took out the box today and will send it back to Edd at BlueSpark for Update of firmware.

The car is running good without the box, no EML’s
McArthur, Did you get your updated firmware box back? hows it running now? Mine is awfully lumpy on Map E now.
User avatar
MrArthur
Experienced Member
Experienced Member
Posts: 205
Joined: Mon Jan 08, 2018 4:14 pm
Location: Stockholm/Sweden
Contact:

Re: Bluespark Tuning Box

Post by MrArthur »

Dansta wrote: Mon Jun 18, 2018 5:40 pm
MrArthur wrote: Fri May 25, 2018 1:43 am
Swirley84 wrote: Tue May 22, 2018 3:14 pm Guys, iv had the box for a good few weeks now and done a 1000 miles which inclded a trip to Nürburgring but today I have had my engine management light come on, car seems to be running fine and I am not sure if is related to the box but anyone had anything similar? Cheers


Sent from my iPhone using Tapatalk
Hi,

I had the same ”drivetrain” error yesterday, driving in map D, very lumpy from 3500 rpm, i took out the box today and will send it back to Edd at BlueSpark for Update of firmware.

The car is running good without the box, no EML’s
McArthur, Did you get your updated firmware box back? hows it running now? Mine is awfully lumpy on Map E now.
No not yet. 🤨
Alpine White BMW M140i 5-door, MPE with carbon tips and front oval muffler delete, PiperCross filter, BlueSpark, Dragy GPS, ZF 8-speed, adaptive, HK, and mutch mutch more, witout moonroof
mokabz
Junior Member
Junior Member
Posts: 5
Joined: Mon Jun 25, 2018 2:34 pm

Re: Bluespark Tuning Box

Post by mokabz »

Newbie to the group. Have owned my M140i for a year and I do regular vlogs on the car. I installed a bluespark box a few weeks ago and it is immense.

Feel free to check out my channel and see what I think about the tuning box.

Here's a link to the channel.

www.youtube.com/c/downshiftthrottle

Got a few things lined up in the pipeline so watch this space!

Thanks in advance!
Dansta
Knowledgeable Member
Knowledgeable Member
Posts: 90
Joined: Tue Mar 21, 2017 11:08 pm

Re: Bluespark Tuning Box

Post by Dansta »

Morning all,

My box went back to Ed last week as the lumpiness wasn’t going away.

Drove the car without it for the first time in a while, it’s so much more responsive without it! You get used to the lag I guess but it was obviously down on power.

Got the box back yesterday and plugged in it and what a world of difference. No lumpiness at all and smiles all round. I’m pretty certain the lag feels reduced too but that may be in my head.

If you’re suffering the lumpy acceleration send it back to Ed and they’ll sort it out. Great service!
User avatar
Barney McGrew
Enthusiastic Member
Enthusiastic Member
Posts: 1607
Joined: Mon Sep 18, 2017 2:43 pm

Re: Bluespark Tuning Box

Post by Barney McGrew »

Dansta wrote: Wed Jul 25, 2018 8:09 am Drove the car without it for the first time in a while, it’s so much more responsive without it! You get used to the lag I guess but it was obviously down on power.

If you’re suffering the lumpy acceleration send it back to Ed and they’ll sort it out. Great service!
I'm wondering whether to do this then, as I took mine off following a drivetrain error (now gone) and realised the car pulls so much more smoothly and without hesitation. So much so I doubt I'd put the box back on again in it's current form. I loved the extra kick from it, but prefer the smoother drive without.

I also noticed when I took it off that the heat of the engine had melted a lot of the internal resin they use in the BS box which had leaked out the back over the connector. The 'resin' looks almost like hot glue and doesn't stand up to the heat off these engines, so I think they should really move over to a proper potting compound if that's what they intend it to be used as.
2017 M140i
Tooney
Experienced Member
Experienced Member
Posts: 395
Joined: Sun Aug 20, 2017 7:38 am

Re: Bluespark Tuning Box

Post by Tooney »

Barney McGrew wrote:
Dansta wrote: Wed Jul 25, 2018 8:09 am Drove the car without it for the first time in a while, it’s so much more responsive without it! You get used to the lag I guess but it was obviously down on power.

If you’re suffering the lumpy acceleration send it back to Ed and they’ll sort it out. Great service!
I'm wondering whether to do this then, as I took mine off following a drivetrain error (now gone) and realised the car pulls so much more smoothly and without hesitation. So much so I doubt I'd put the box back on again in it's current form. I loved the extra kick from it, but prefer the smoother drive without.

I also noticed when I took it off that the heat of the engine had melted a lot of the internal resin they use in the BS box which had leaked out the back over the connector. The 'resin' looks almost like hot glue and doesn't stand up to the heat off these engines, so I think they should really move over to a proper potting compound if that's what they intend it to be used as.
Where is your box located it shouldn't be on or near your engine?


Sent from my iPhone using Tapatalk
M2 Competition Hockenheim Silver
User avatar
Barney McGrew
Enthusiastic Member
Enthusiastic Member
Posts: 1607
Joined: Mon Sep 18, 2017 2:43 pm

Re: Bluespark Tuning Box

Post by Barney McGrew »

I cable tied it to the edge of the engine bay, as far as I could get from the actual block.

Not much choice about not being near the engine when it has to go in the engine bay.
2017 M140i
Post Reply

Return to “Bluespark Automotive”